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1 Requirements and installation

In order to run ANIMO, a desktop or laptop computer is needed with the following software installed:

• Java: see Section 1.1

• Cytoscape (www.cytoscape.org): see Section 1.2

• UPPAAL (www.uppaal.org): see Section 1.3

The software to run Java-based programs is provided for free by Oracle. More information is avail-
able on the java.com website. Cytoscape is an open source project released under the terms of the
GNU Lesser General Public License. UPPAAL is developed by a collaboration by the universities of
Uppsala (Sweden) and Aalborg (Denmark), and is free for non-commercial applications in academia
only.

All of these software work under Windows ( ), Mac-OS ( ) and all most common GNU/Linux ( )
distributions. If the requirements are already met, ANIMO can be directly installed following the
instructions in Section 1.4.
Note: when required to type something, the text to input will be represented “like this”: the
quotation marks are not intended to be typed.
In case of problems accessing a web site with Microsoft Internet Explorer, we advise to try with a
different web browser (such as Mozilla Firefox or Google Chrome) or to update Internet Explorer.

1.1 Java

1. In order to check that Java is installed, open a console

Windows 7: press Windows button and type “cmd”, then press Return. Previous versions:
in the Start menu find All programs → Accessories → Command Prompt.

Go to Applications → Utilities → Terminal.

Under Gnome, press Alt-F2, type “gnome-terminal”, then press Return. Under KDE,
press the KMenu button, type “konsole” and click Konsole. Under Unity, press the home
button (the one with the Ubuntu logo: ), type “terminal” and click the Terminal icon.

2. Type “java” and press Return. If a brief error message like “unknown command” is shown,
Java needs to be installed: please proceed to step 3. Otherwise, please continue to Section 1.2.

3. Point your web browser to java.com.
Click Free Java Download, then on Agree and Start Free Download.
If asked for permission to run the installer, grant that permission.
After the download, double click the installer and install Java following the guided steps.
To check that Java has been correctly installed, a web page is automatically opened at
the end of the installation process. Click on Verify Java version. If a Congratulations!
message is shown, Java has been successfully installed. Otherwise, please try again or
contact Java support.

If you run Ubuntu, open the Software centre, search for “java” and select OpenJDK Java
7 Runtime. An Install button will appear next to the name of the package: click that
button and Java will be correctly installed.
If you run another distribution, use your package manager in a similar way. If you
cannot find OpenJDK, there may be the possibility to install Oracle Java Development
Kit (JDK) instead. In any case, please make sure that the installed Java version is at
least 7.
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1.2 Cytoscape

Cytoscape can be found at the address www.cytoscape.org/download.php: an automatic installer
program can be downloaded. Please note that you need to register and accept Cytoscape’s terms
of use before being able to start the download. Choose the latest version (at least 3.2.0), possibly
using a platform-specific installer. You can choose 64bit only if you know that your computer can
run 64bit programs, otherwise it is safe to choose 32bit.

1.3 UPPAAL

1. Point your browser to www.uppaal.org.
Note: UPPAAL is free only for academic use. Information and contacts for commercial licenses
can be found on the web site.

2. Click the Download link, and choose the latest development version (at least 4.1, NOT 4.0)
for your operating system.

3. Fill in the required contact information and click the Accept and download button to download
UPPAAL.
Note: problems with the registration on UPPAAL website have been reported when using
some versions of Microsoft Internet Explorer. If the registration is unsuccessful, please consider
updating Internet Explorer or changing your web browser.

4. Unzip the downloaded file to a known location: UPPAAL will be installed there.

5. Complete UPPAAL installation.

Open the UPPAAL installation location in Finder, drop the UPPAAL.App icon in your
Applications folder, and copy the verifyta executable file to a known location. The
installation of UPPAAL is complete: go to Section 1.4.

Open a console (this was done in Sec. 1.1, step number 1), type “cd PATH_TO_THE_

UPPAAL_DIRECTORY” and press Return; PATH_TO_THE_UPPAAL_DIRECTORY is the path to
the directory where you installed UPPAAL. It can be for example “c:\Users\myuser\
Desktop\uppaal-4.1.19”, or “/home/myuser/programs/uppaal-4.1.19”.

Note: some Windows users may have access only to specific partitions (D:, Z:,. . . ): in
that case, please first change to the corresponding drive letter where the downloaded file
was extracted. For example: if UPPAAL is located in d:\myuser\Programs\uppaal-4.

1.19, the two commands to be entered are
“d:”
“cd \user\Programs\uppaal-4.1.19”

6. Type “java -jar uppaal.jar” and press Return.

7. The license for UPPAAL will be automatically acquired, and the main window of UPPAAL
user interface will appear: you may now close that window.

1.4 Installing ANIMO

1. ANIMO is free only for academic use. For commercial licenses, please contact us at
.

2. Run Cytoscape.

3. Click the menu command Apps → App Manager : the App Manager window will open.

4. Click on ANIMO in the list of available apps and then on the Install button. ANIMO will be
automatically downloaded and installed.
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5. You can close the App Manager window.

6. ANIMO will automatically try to locate the verifyta executable included in UPPAAL, which
is needed to verify Timed Automata models. If you know the location where you installed
UPPAAL, you can just stop the process (press on the small X on the right), and indicate the
location of the verifyta executable. You can find it

where it was copied at step 5 in Section 1.3

in the bin (bin-Linux, bin-Win32, . . . depending on your operating system) directory
inside the UPPAAL installation directory, where it was unzipped at step 4 in Section 1.3

7. ANIMO is correctly installed and ready to be used.
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2 ANIMO user’s manual

We will now present a step-by-step sequence to obtain an example model with ANIMO, which will
allow us to illustrate the main features of the tool.

2.1 Modelling a small network

1. Run Cytoscape.

2. If Cytoscape is already running and there are open documents, please make sure that the
current work is saved before proceeding.

3. From the File menu, select New → Session. Answer positively to the question “Current
session (all networks/attributes) will be lost. Do you want to continue?”.

4. From the File menu, select New → Network → Empty Network.

5. Click OK in the Create New Network dialogue. A new white window will open: there we will
insert the nodes for the new network.

6. Add 5 nodes to the empty network by right-clicking on empty areas of the Network window,
and selecting Add → Node.
Note: right-clicks are available only on mice with at least two buttons. On Apple mice, or
devices with only one button, it is necessary to keep the button with the symbol (or possibly
Ctrl) pressed while clicking.

7. The Edit reactant dialogue window is opened every time a new node is added, or when you
right click an existing node and then select the ANIMO → Edit reactant. . . item from the
menu, or when you double-click on an existing node. Use that window to set the properties
of the nodes as indicated in Table 1, taking the setting in Figure 1 for node A as reference.
When the properties of a node have been inserted, confirm the choice with the Save button.

Table 1: The settings for the nodes (signalling network components) in the example.

Name
Total act. Initial act.

Molecule type Enabled? Plotted?
levels level

A 15 15 Cytokine Yes No

B 15 0 Receptor Yes No

C 15 0 Other Yes No

D 100 0 Kinase Yes Yes

E 1 1 Phosphatase Yes No

8. In order to add an edge to the network, right-click on the node from which the edge should
start, select Add → Edge, and click on the node where the edge should arrive. Add the
following edges: A → B, B → C, C → B, B → D, E → D.

9. The Edit interaction dialogue window is opened when you add a new edge, or when you right
click an existing edge and then select the ANIMO → Edit interaction. . . item from the menu,
or when you double-click on an existing edge. Use that window to set the parameters of the
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Figure 1: The Edit reactant window: modifying the properties of node A. The Description box in the Edit reactant
dialogue can be used to add comments about what a node represents or where its reference was found in literature: when
keeping the mouse cursor over that node in the network, the description text will be shown as tool-tip.

edges as indicated in Table 2. The settings for the edge A → B should reflect the ones shown
in the Interaction A → B window in Figure 2.
Note: In order to insert a qualitative parameter like the ones required by the example network,
click once the slider in the parameter box to activate it, and then move the slider to match
the requested value.

Table 2: The settings for the edges (interactions) in the example.

Interaction Influence Scenario Parameter value

A → B Activation 1 Medium

B → C Activation 1 Slow

C → B Inhibition 1 Fast

B → D Activation 1 Slow

E → D Inhibition 2 V. Slow

10. In the Control Panel, make sure that the ANIMO tab is selected by clicking its title.

11. Insert a value of 120 minutes in the Simulation box.

12. Click the Analyse network button (alternatively, you can press Return after inserting the
number of minutes).

13. After a few seconds the Results Panel should appear on the right, showing a plot of the activity
level of reactant D over a time course of 120 minutes. Figure 3 shows the resulting network
and graph plot.
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Figure 2: The Edit interaction window: modifying the properties of edge A → B. There is a Description box also for
interactions: it can be used with the same aim as for nodes.

2.1.1 Managing simulation data and activity levels plots

Each time a simulation result is obtained, a new tab is added to the Results Panel (see the right
part of Fig. 3) in which we identify a set of buttons, a plot of the activity levels of the selected
reactants and a time slider.

The buttons above the graph have the following purposes:

Change title allows to select a new title for the tab: this can be useful e.g. when comparing
different simulations made on similar configurations of the same network.

Reset to here restore the network to the state it was in when the simulation that gave the current
graph was performed. If no simulation was done with the network in its current state, the
current network configuration will be lost.

Difference with. . . allows to compute a difference between two simulations. After pressing this
button, select another graph (i.e. another tab in the Results panel) and click on the Difference
with this button: a new graph will be shown, highlighting the differences between the two
selected graphs (first - second). The slider under the graph can be used to visualize the
differences in node activity over the course of the simulation, using this color scale: red =
“the node is less active in the first simulation than in the second”, green = “more active”,
white = “similar activity level”.

Save simulation data. . . allows to save the simulation data of the current tab on a .sim file,
which can then be loaded and inspected in the future. The Load simulation data. . . button
in the Control Panel above the Simulation box can be used for this purpose. Please note that
the best results are obtained only when loading a .sim file when the Network window contains
the same network on which the simulation data are based. If no network is currently opened,
a network will not be opened by loading a .sim file.

Close close the currently displayed graph.

Right clicking inside the graph area will bring up a menu that allows to perform some basic
operations with the graph and its data:

• Add data from CSV : superpose the graph with other data series found in a .csv (comma
separated values) file. This file type can be obtained for example by exporting data from the
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Figure 3: The completed example, where also the feature that allows to view the activity levels of reactants at chosen
simulation times is demonstrated: the vertical red bar in the graph on the right can be moved using the slider under the
graph, and indicates the point in the time series on which the colouring of the nodes in the Network window is based. The
legends for colours and shapes can be found in the Legend panel.
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default Excel format. If you want the data in the .csv file to be rescaled so that its maximum
Y value coincides with the maximum in the plot, the data file needs to contain a column
named (exactly) Number of levels, on the first row of which the maximum of the scale for the
.csv data needs to be put. For example, if the data in the .csv file are on a 0-100 scale, the
value for Number of levels will be 100.

• Export : this sub-menu contains options to export the currently visualized data

– Save as PNG : save the graph as it is shown in a .png image file. This file format can be
opened by most image editors.

– Export visible as CSV : export to a .csv file all the series that are currently visible (i.e.,
not hidden) in the graph.

• Manage data series: opens a new dialogue window (see Fig. 4) that allows to manage the series
plotted in the graph, mostly with the same effect as the shortcuts explained in Subsection 2.2.
The available features are:

– manually sort the data series (they are sorted alphabetically by default) by dragging and
dropping them using the handles on the left

– choose whether to show or hide a data series by checking or unchecking the corresponding
checkbox

– rename a series using the text box

– change the colour of a series choosing among the list of available colours

– change the way a series shows its error bars (when supported), using one of the available
methods

– in case a series with error bars is to be displayed using dots (option “Dots and bars” for
the error bar type), choose the shape of the dots among the ones available

All changes performed in this dialogue are immediately reflected in the graph.

• Zoom: this sub-menu contains commands to change the scale of the graph, managing its zoom
level

– Graph interval : change the lower and upper bounds for X and Y axes.

– Zoom rectangle: zoom the graph around a user-chosen rectangular area. After selecting
this command the shape of the mouse cursor changes into a cross. The area of the plot
to be zoomed can then be selected by dragging a rectangular selection around it (see the
definition of rectangular selection on page 9).

– Zoom extents: bring the zoom level back to default, cancelling the effects of any Zoom
rectangle command.

• Graph type: this sub-menu allows to change the type of the graph, using different ways to plot
the data

– Step-shaped graph: in order to display more faithfully data series with low granularity,
this option can be chosen. It explicitly keeps each data series constant until the next
point in which its value changes, thus producing a graph that contains many “steps”.

– Normal graph: the default way to display data series from a simulation: plot the activities
as lines using the X axis to represent simulation time and the Y axis to represent activity
levels.

– Heat-map graph: alternative way to represent activity levels: use the activity scale as
defined in the Legend panel (the colours can be changed using Cytoscape’s visual style
options for node colour) to plot the activity levels against simulation time. Each data
series occupies a fixed position on the Y axis, while the X axis is used to represent time.
When 10 or more series are chosen to be plotted, this option is automatically selected.
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– X vs Y : plot the values of one data series against another. A dialogue will open that
allows to choose among the series currently present in the graph which one should be
represent by X axis, and which by Y axis. When in this mode, the slider under the
graph will move a dot on the graph instead of a vertical bar, as different time points have
different coordinates both in X and Y.

• Clear Data: clear the contents of the graph, removing all series. This can be useful for plotting
a .csv file without superposing it to the current graph, or for loading a file in which all hidden
data where removed (exporting the visible graph to a .csv with the previous command).

Figure 4: The Manage graph series dialogue: reorder, hide/show, rename, change the colour and error-bar style of the
series present in the graph. The option to change the way error bars are represented for a data series is present only if
that data series has an associated standard deviation. This situation occurs when the data series represents the average of
a number of simulations (see the description of such tools in Subsection 2.2), or when the data series was loaded from a
.csv file which contains error estimates (see instructions on how to prepare .csv files including error estimation data series in
Subsection 2.2). The Change plotted series button allows to select which nodes of the network are displayed in the graph:
initially, only nodes marked as plotted when a simulation is performed are included in the graph; with this button it is still
possible to change the set of plotted nodes without the need to perform a new simulation.

Whenever the result of one or more simulations is shown as a graph, it is possible to use the slider
under the graph to move through the entire simulation, showing the activity levels of all reactants
represented with different node colouring in the Network window on the left. For an example, see
Figure 3: the vertical red line in the graph represents the time instant on which the colours of the
nodes in the Network window are based, and can be moved with the slider over which the mouse
cursor is drawn.

Finally, the Copy button beside the slider ( ) can be used to set the activity levels in the
network to the time point selected with the slider. This is useful if for example we want to change
some conditions from a certain point in a simulation.

2.1.2 Editing a network in Cytoscape

Nodes and arcs can be placed in the network as shown previously: right click on an empty space
in the Network window and select Add → Node to add a node; right click on the source node and
select Add → Edge, then click on the target node to create a new edge between the two nodes.

In order to delete a node/edge, select them by clicking or grouping them in a larger rectangular
selection, and then press the Delete key on the keyboard or select the Edit → Delete Selected Nodes
and Edges menu command.
Note: in order to obtain a rectangular selection, left click in the Network window where the upper-
left corner of the rectangle should be and, without releasing the left mouse button, drag the mouse
cursor to where the lower-right corner of the rectangular selection should be; then release the left
mouse button. All the entities which were even partially touched by the rectangle are now selected.
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Navigation inside the Network window can be performed by clicking and dragging the centre
mouse button, while zooming can be done by either rotating the mouse wheel or clicking and
holding the right mouse button while moving the mouse in a vertical direction. In case no central
mouse button is available, the Network tab in the Control Panel will allow to navigate the network,
together with the zoom buttons available in Cytoscape’s toolbar (where the open and save icons
are).

Finally, note that the colours used to represent node activity can be changed using the Style tab
in the Control Panel. Please refer to Cytoscape’s manual to do that.

2.2 ANIMO features

Nodes and edges (and groups of nodes/edges highlighted via a rectangular selection) can be disabled
by choosing ANIMO → Enable/disable from the right-click menu: they will be represented with less
saturated colours and can be re-enabled by performing the same action. Moreover, a node can be
enabled/disabled directly in its properties window, where it is also possible to add/remove the node
from the list of series appearing in the graph resulting from a simulation of the network by selecting
Plotted or Hidden (see also Figure 1): nodes that will be plotted have a blue border. Every enabled
node will be taken into account when computing the evolution of the system, but only nodes marked
as Plotted will appear in a graph. All edges connecting disabled nodes are automatically disabled.

Each plot in an ANIMO Results tab contains by default a legend, which can be used to modify
which series are displayed and how they are displayed. Clicking with the central mouse button on
a series name will hide it from the graph, while a centre-click on the coloured line beside the series
name will change the colour of that series, cycling through a predefined set of available colours.
The entire legend can be hidden by clicking with the central mouse button anywhere on the graph
(not inside the legend), or it can be dragged around by clicking and holding the left mouse button,
releasing it when the preferred position is reached. Rotating the mouse wheel will allow the thickness
of all the graph lines, and the size of the text, to grow or decrease: this feature can be useful when
the window containing the graph is very large.

If the model is non-deterministic, i.e. its evolution is not expected to be exactly the same for
every single simulation run (see the uncertainty settings in Options, Section 2.6), it is possible to
ask ANIMO to perform a number of simulation runs in a batch, plotting the averages of the activity
levels over the runs together with a standard deviation value, or showing a so-called overlay plot
where all runs are plotted over each other. The controls that allow to ask for multiple simulation
runs can be found in the Control Panel, inside the Simulation box.

Standard deviation may be represented in the graph: it is normally shown as vertical bars, but
its aspect can be cycled through five possibilities (vertical bars, shading, both bars and shading,
bars and symbols, none) by right-clicking the corresponding line in the legend. Symbols associated
to a representation of standard deviation can be changed by Shift-right-clicking (holding down the
Shift key, right click) on the corresponding line in the legend. Standard deviation values can be
obtained when asking for multiple simulations in the network analysis, but they can also be present
in a .csv file, e.g. when the file contains averages of (replicated) experimental data. In a .csv file,
the column containing the standard deviation values for column A should be named A StdDev for
ANIMO to recognize it and properly display the data series with the associated error values.

2.3 Parameter settings

The application of some basic strategies when setting the parameters for a network allows the
less experienced users to considerably shorten the modelling time. First of all, it is important to
proceed in a top-to-bottom order, trying to match a component to the corresponding data before
inserting the components downstream thereof. Second, when choosing the kinetic parameter for
an interaction, we advise to first use the qualitative settings (very slow, slow, medium, fast, very
fast): this allows to define the relative speeds of the interactions as soon as possible, leaving the
more precise parameter setting procedure as a follow-up step. Finally, as can be seen from the
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parameter settings of Section 2.1, in order to obtain a peak behaviour it is particularly important
that a negative feedback is present (as an example, see the interactions involving B and C in Tab. 2),
and that the inactivating interaction in the loop is faster than the ones activating the target node.

Once a satisfying profile is obtained, the parameters can be rescaled in groups or all at the same
time. This allows us to easily match a model against experimental data that show a similar profile
on a different time scale (e.g., the model produces a peak similar to the one in the data, but 20
minutes too early). In order to rescale a set of reactions, select the corresponding edges in the
Network window, right click on one of the selected edges and choose ANIMO → Rescale k value(s)
from the menu. In the new dialogue, insert the scale factor that will be applied to the selected
reactions and press OK : the new values will be automatically computed and set by ANIMO.

2.4 Opening a Timed Automata model generated by ANIMO

All Timed Automata models generated by ANIMO in a Cytoscape session are available until Cy-
toscape is closed, and can be usually found in the system temporary directory. In order to know
exactly where the Timed Automata model for a particular simulation was saved, check the Cy-
toscape log (small button on the lower-left-most corner in Cytoscape): it contains the advancement
status of all the executed tasks, including ANIMO simulations. Before beginning the analysis, each
simulation task explicitly outputs the location of the file that is going to be analysed. Opening
the same file with UPPAAL will allow the interested user to inspect the model by themselves, and
query it for other properties directly in the UPPAAL user interface.

2.5 Updating ANIMO

To check whether a new version of ANIMO has been published, run Cytoscape and open the app
manager via the menu command Apps → App Manager. In the Check for Updates tab the available
updates will be listed: if a new version of ANIMO was published, it will appear in the table. Select
it and press Update Selected, or just press Update All to update all apps. Cytoscape will download
and install the new versions of the apps.

2.6 ANIMO Options

In the Control Panel, the ANIMO tab contains also an Options. . . button: it is located below
the Legend. Pressing that button will open the options dialogue for ANIMO, where the following
configuration settings can be changed:

location of the verifyta executable : the location of verifyta can be changed if for example a
wrong location was previously selected, UPPAAL was not already installed when ANIMO was
run for the first time, or a new version of UPPAAL has been installed

uncertainty in reaction parameters : a degree of uncertainty can be set for the k parameters
of all the reactions in ANIMO models, introducing some non-determinism in the simulations.
For example, if a value of 5% uncertainty is chosen, a given reaction that would normally take
exactly 10 seconds to perform will occur after a number of seconds randomly chosen from a
uniform distribution in the closed interval 9.95, 10.05. The default value for uncertainty is 5,
so reaction times are as described by default. In order to get a deterministic model (especially
useful to make model checking much easier for the computer), set this parameter to 0, i.e.
uncheck the option.

type of underlying Timed Automata model : two types of Timed Automata models are avail-
able: reaction-centred and reactant-centred. The latter is in general more efficient and is se-
lected by default. The difference between the two models can be seen by opening the models
generated by ANIMO when each choice is made.
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